Go Back   Maryland Shooters > The Arsenal > Rifles
Don't Have An Account? Register Here

Join MD Shooters
Reply
 
Thread Tools Display Modes
Old August 14th, 2013, 09:22 PM #1
omegaZ87's Avatar
omegaZ87 omegaZ87 is offline
Junior Member
 
Join Date: Apr 2013
Location: Maryland
Posts: 52
omegaZ87 omegaZ87 is offline
Junior Member
omegaZ87's Avatar
 
Join Date: Apr 2013
Location: Maryland
Posts: 52
Major Issue with my first AK !!!

Hey everyone,

Not sure if you remember but over 3 months ago I wrote about how I bought my first severely overpriced assault rifle due to being in panic mode from seeing empty shelves at every LGS. It was a Romanian WASR-10 that I paid a bit over a grand for.

Well it just came in over the weekend and I took it to the range hoping that the fun I would have putting 200 rounds of TULA through it would take my mind off the 500 dollar premium that I paid.

Pulled the trigger and it went BOOM. but would not do anything after the second pull. I looked and noticed the bolt about 30% of the way back with the shell casing sticking halfway out of the barrel, still held onto by the extractor.

I manually pulled the bold back and ejected the casing and tried shooting it again, only to have the same problem occur. This happened for every single shot in a mag of 20 rounds. I tried using different ammo, but same thing. Tried using different mags but same thing.

I have no idea what is going on but I am extremely pissed that I paid 1000 dollars for something that has essentially turned into a 'bolt-action' rife as I need to manually eject and chamber the round after each shot.

Has anyone ever dealt with this before or know what can be done to fix the issue? Please assist!
omegaZ87 is offline   Reply With Quote
Old August 14th, 2013, 09:26 PM #2
Sling Blade's Avatar
Sling Blade Sling Blade is offline
Unejamacated hick
 
Join Date: Feb 2013
Posts: 26,468
Sling Blade Sling Blade is offline
Unejamacated hick
Sling Blade's Avatar
 
Join Date: Feb 2013
Posts: 26,468
Brace yourself partner. All the haters will show saying "well it's a WASR. No wonder it's screwing up" with nothing helpful to tell you otherwise.

I haven't shot mine yet. Hopefully I have better luck.

Try chambering a round, and then pulling the mag before you shoot. That will eliminate one variable while trying to solve your mystery.
__________________
Sling Blade is offline   Reply With Quote
Old August 14th, 2013, 09:32 PM #3
peckman28's Avatar
peckman28 peckman28 is offline
Member
 
Join Date: Aug 2010
Location: Bowie
Posts: 148
peckman28 peckman28 is offline
Member
peckman28's Avatar
 
Join Date: Aug 2010
Location: Bowie
Posts: 148
Well sir....the usual questions apply here. You cleaned it thoroughly before taking it out right? This includes cleaning out the gas tube, disassembling the bolt and carrier and fully cleaning those, etc. I have a Romanian as well and it failed me a few times on its initial outing....turned out there was some cosmoline in there I had missed on my first scrub-down. It has been drama-free ever since, as just about all Romanians are. The other possibility, based on what info you have here, is that your extractor is out of spec. Hopefully it's just the former...good luck. I hope you get it running right; they really are a lot of fun.
peckman28 is offline   Reply With Quote
Old August 14th, 2013, 09:35 PM #4
aquaman's Avatar
aquaman aquaman is offline
Senior Member
 
Join Date: Sep 2008
Location: Belcamp, MD
Posts: 7,304
aquaman aquaman is offline
Senior Member
aquaman's Avatar
 
Join Date: Sep 2008
Location: Belcamp, MD
Posts: 7,304
so the gun went off and the bolt went back 30% of the way and the extractor never let go of the empty shell?
aquaman is offline   Reply With Quote
Old August 14th, 2013, 09:37 PM #5
Name Taken Name Taken is online now
Senior Member
 
Join Date: Feb 2010
Location: Central
Posts: 11,531
Name Taken Name Taken is online now
Senior Member
 
Join Date: Feb 2010
Location: Central
Posts: 11,531
It's an AK...so user error. Gotta be user error.
__________________
"The way to get people out of poverty is to make them uncomfortable in their poverty." -- Ben Franklin

"We sleep safe in our beds because rough men stand ready in the night to visit violence on those who wish us harm." ---George Orwell
Name Taken is online now   Reply With Quote
Old August 14th, 2013, 09:39 PM #6
Sling Blade's Avatar
Sling Blade Sling Blade is offline
Unejamacated hick
 
Join Date: Feb 2013
Posts: 26,468
Sling Blade Sling Blade is offline
Unejamacated hick
Sling Blade's Avatar
 
Join Date: Feb 2013
Posts: 26,468
Quote:
Originally Posted by aquaman View Post
so the gun went off and the bolt went back 30% of the way and the extractor never let go of the empty shell?
I thought maybe the shell casing is sticking in the chamber, like the cartridge was undercharged or something. But he said he tried different ammo with the same result. A good cleaning may be in order, assuming he hasn't done it already. If not that, than a lighter recoil spring may be necessary.
__________________
Sling Blade is offline   Reply With Quote
Old August 14th, 2013, 09:41 PM #7
marko marko is offline
Banned
 
Join Date: Jan 2009
Posts: 6,984
marko marko is offline
Banned
 
Join Date: Jan 2009
Posts: 6,984
I'd go with disassembly and cleaning first.
marko is offline   Reply With Quote
Old August 14th, 2013, 09:43 PM #8
Sling Blade's Avatar
Sling Blade Sling Blade is offline
Unejamacated hick
 
Join Date: Feb 2013
Posts: 26,468
Sling Blade Sling Blade is offline
Unejamacated hick
Sling Blade's Avatar
 
Join Date: Feb 2013
Posts: 26,468
Quote:
Originally Posted by marko View Post
I'd go with disassembly and cleaning first.
Definitely. Before replacing any parts.
__________________
Sling Blade is offline   Reply With Quote
Old August 14th, 2013, 09:44 PM #9
Wendigo's Avatar
Wendigo Wendigo is offline
Hungry
 
Join Date: Mar 2013
Location: Reisterstown
Posts: 1,389
Images: 7
Wendigo Wendigo is offline
Hungry
Wendigo's Avatar
 
Join Date: Mar 2013
Location: Reisterstown
Posts: 1,389
Images: 7
Sounds like some sort of blockage in the gas port or tube, or maybe the bolt is holding up on something under the dust cover. Take it apart, look for anything obvious.
__________________

"Be Not Afraid, Our Faith is Our Courage"
Wendigo is offline   Reply With Quote
Old August 14th, 2013, 09:45 PM #10
rob-cubed's Avatar
rob-cubed rob-cubed is offline
In need of moderation
 
Join Date: Sep 2009
Location: Holding the line in Baltimore
Posts: 5,207
rob-cubed rob-cubed is offline
In need of moderation
rob-cubed's Avatar
 
Join Date: Sep 2009
Location: Holding the line in Baltimore
Posts: 5,207
Yep, take her apart and scrub her down. Make sure you clean out the gas port real well (dump a good amount of cleaner into the gas block). Sounds like it may be undergassed, possibly due to obstruction. Cycle the action by hand to ensure the carrier isn't hanging up anywhere. You should feel some resistance when it rides over the hammer, otherwise it should be smooth and even a little sloppy.
rob-cubed is offline   Reply With Quote
Reply

  Home Page > Forum List > The Arsenal > Rifles

Tags
ak47, ak74, assault, wasr, wasr10


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:47 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
2021, Congregate Media, LP Privacy Policy Terms of Service